Portal | Homepage | Blog

Inactive Item sold on Amazon


#1

Under what condition is an Item removed from Amazon? We had an item that was sold on Amazon that had been marked inactive. I verified that the item movement was correct and the item was sold in our brick and mortar store on Oct 27th and I verified the QTY was then at 0. Since this item was discontinued, one of the store personnel marked the item as inactive but for some reason today (Nov 15th) we received an Amazon order for the item. It is not been on our website since it was marked inactive and I was under the assumption if it was not on our website, it was not in our Amazon store.

Please advise.

Bob


#2

Hi Bob,

Can you verify that your deletion/removal feed is disabled in the main configuration section for Amazon please?

When you say mark as inactive, do you mean setting the AmazonItem field to false, or do you mean removing it from your webstore entirely?

Also, would you mind supplying the item lookup code so we can investigate it directly.

Kind regards,
Donogh


#3

Hi Donogh

I cannot verify that the deletion/removal feed is disabled because I have no idea what you are talking about. Under my feed summary I see the statuses but I can’t find any thing to do with deletion/removal feed. Tell me where to find it.

When I say the item is inactive, I mean that the RMS Inactive flag is set to True. In the past, even if the web item flag is set to true, as soon as the inactive flag is set to true, then the item came off the website regardless of the status of the web item flag. My concern is that the Amazon field does not work this way.

The item sku is WAL9333253.

Bob


#4

Hi Guys

We had a similar problem We seem to be having a problem with quantities on Amazon. We had 5 of a costume in stock yesterday and sold 3 of them in one order, leaving us with two in stock but the settings on Amazon should take the item down when there are 2 or less in stock. We have since sold the remaining two in separate orders. One of these was processed around 10am this morning leaving our system at 0 but Amazon is still showing 1 in stock as shown in the attached image. I have since set this to 0 in Amazon manually to prevent any problems if it is ordered.


#5

To resolve this issue we have modified your Amazon Inventory Feed.

With the default settings, we only feed the inventory feed once the product feed is successful. If, for any reason your product feed stops working, the inventory won’t update. This is what appears to have happened in both reported situations.

To get round this we have modified your inventory feed setting to ‘Forced’. With this setting the inventory feed will get sent to Amazon regardless of the status of the product feed. So even if the product feed fails your Inventory feed will be sent to Amazon and update your product levels.

James


#6

Thanks James

One last question regarding this issue. If in RMS we set the Inactive Flag to true does it matter to the feed the state of the Amazon flag?

Bob


#7

Thanks James

Regards
David


#8

Hi Bob,

I’ve just reviewed your field mappings. This is the filter on your product table:

<FILTER>(webitem=1 AND inactive=0) OR DropShipWebStock = 1</FILTER>

That means that a web item will be removed if it’s NOT marked as a web item OR it’s marked as inactive. For those items marked for drop ship, that rule is ignored.

Once an item is removed from the webstore it is automatically removed from Amazon.

I have verified that your deletion feed is running:

Kind regards.
Donogh


#9

Thanks Donogh for taking care of this. Just so you know, under my feed summary I have them all except the deletion one. Doesn’t really matter, but it looks like once it’s set, we don’t have to mess with it.

Bob


#10

Spot on Bob. We are releasing an update soon to ensure that the deletion feed’s status is always displayed also. Right now, you can only see it when you go through the setup configuration wizard.

Thanks for the feedback!

Donogh


#11

HI guys, remember me?

Just wanted you to know another inactive item (in RMS) sold on Amazon again last night. THis item (RMX852068) was set inactive on Dec 7th. I noticed that when it was set inactive it actually had 1 in stock (not sure why) and the Amazon flag was still turned on (True) as well as the Web Item was still turned on (True). So when the employees are setting an item inactive (because we are told it is discontinued), they are doing so without regard for the status of the Amazon flag, the web item flag or even if there is inventory.

And for some reason it sold last night. I verified it is not on our web site.

The good news is that it was a 1991 Pontiac Firebird 1:24 scale model kit and we have a 1992 and of course we all know there wasn’t too much of a difference between those years. So we are going to try and convince the customer to take the '92 kit.

Anyways, is leaving the amazon flag on while marking an item inactive causing this? Our field mapping has not changed from what is display above in this thread.

Also on the Amazon portal, the item is still there and says Inactive (Out of Stock). In our Nitrosell Amazon portal the item says removed.

Bob