Portal | Homepage | Blog

Alert When Adding in PAM

Every now and then when I enter information in PAM an alert pops up after I hit “Commit” and it doesn’t save the information I just entered. The alert is called “Pending Updates Completed Partially” and instructs me to look at the “Modified and Conflicting” filter. Why is this happening? I can go weeks without seeing the alert and some days I see it multiple times.

Hi Sam,

The way PAM works is that when you open it up it takes a snapshot of the database so you can work on it. Occasionally after you make some changes (especially while working on larger datasets) another source, such as POS operation, another user etc. might have changed those records. In those cases you could be receiving this notification. Usually working on smaller sets or coordinating your work with other users of the database helps.

I hope this helps but if you have any questions please let me know.

Regards,

Peter

1 Like

That was our consensus as well. However, the issue is that when these notifications appear on my end I am the only employee with PAM running and also the only employee making changes to the companies database. I have been able to work around the issue by creating one or two keywords at a time, saving, and then adding one or two keywords at a time. When these notifications pop up and I continue to add more keywords or key phrases at once then the notification pops up again. It is weird but I was able to work around it.

Somewhat similar issues here with PAM. Sometimes unable to change more than one field in a given product without changes being discarded. Have to work-around it by only changing one thing at a time, then commit changes which over time, can be quite time consuming.

1 Like

That is exactly what I have learned needs to happen. Even when I make sure everything before was “committed” sometimes trying to add more than one “keyword” or key word phrase at a time just erases everything. Very frustrating.

We know of a bug that erases all your changes in PAM, although this doesn’t cause the pop up alert message described by @seforaker.

Just mentioning it as it could be related.

PAM lets you type in more characters than some of the database fields allow Eg Theme and Brand are limited to 50 characters in the database but PAM lets you happily type more. Keywords is 250 characters. If you’ve typed more, then when you try and commit, PAM doesn’t catch the error or show you a message, it doesn’t save any changes to any rows since your last commit, and refreshes the data from the database so you lose everything.

If PAM isn’t catching this database error, maybe its not catching others too?

Hi @seforaker @emma @callum

I have notified our support team to take a look at that and how we can improve. We’ll get back to you with an update.

Regards,

Peter

Hi @seforaker @emma @callum

Unfortunately, I couldn’t replicate this issues on our testing environment.

It might be something specific to the PAM version you’re using or other settings.

Could you please open a ticket about it?

You can include a link to this forum topic with the rest of the details, and we’ll have our support team on it.

Kind regards,
Kamil