Portal | Homepage | Blog

301 Redirects - URL Collision Error


#1

Hi there,

I am trying to add a 301 URL redirect from the following link:
http://www.andersonplywood.com/butcher_blocks_black_walnut.htm
to:
http://www.andersonplywood.com/butcher-blocks-countertops/black-walnut/

Here

Would you please advise?

Best,
Mohsen


#2

Hi Mohsen,

You need to remove the domain from the URL, the format for the old URL needs to be like this:
/myolddepartment/bikes/whitebicycle.html' in your example it should be: ‘/butcher_blocks_black_walnut.htm

I have tried to insert the URL with the right format and I got the same message.
The issue comes because you have a content page called: “Black Walnut Butcher Block” and even if for this page you have customized the URL the system still give you the possibility to go back to the non customized URL that in this case is:

Content:
Format: /%content_name%/
Example: /MSDS-Sheets/
Version: 1

If you did so, there would be a collision between the URL you are trying to introduce and the default URL, so the system doesn’t allow it.

You could solve it adding the content id to the defaults URL: '/%content_name%/%content_id%/'

Best regards,
Belen


#3

Hi Belen,

Thanks for your explanation and the fix.
It worked for me.
Just one more question:
Where can I see a list of my redirects? Just in case I need to edit or delete them later?

Best,
Mohsen


#4

Hi Belen,

One more question:
My assumption was when I change a URL format, the older URLs will be redirected to newer URLs.
Isn’t that true? Seems like not?!
Since I updated the URL formats, we are getting tons of “page not founds” in our GWT.

Can you please advise?

Best,
Mohsen


#5

Hi Mohsen,

Yes, the old URLs are redirect to the new ones. Could you provide us with an example where this is not happening?

To see a list of all the redirects that are in place in your domain you could use this free tool.

Best regards,
Belén


#6

Hi Belen,

Here is two examples:
1 -
Old URL:
http://www.andersonplywood.com/HARD-SANDER-BACKING-PAD-FOR-ETS-150-LEX-150-SANDERS,-D150,-1-PACK-Festool-FES498988/
New URL:
http://www.andersonplywood.com/HARD-SANDER-BACKING-PAD-FOR-ETS-150-LEX-150-SANDERS%2C-D150%2C-1-PACK-Festool-498988-FES498988/

2-
Old URL:
http://www.andersonplywood.com/Phenolic-Plywood/
New URL:
http://www.andersonplywood.com/Phenolic-Plywood/284/


#7

Hi Mohsen,

In the first example, there are commas. I imagine that you have taken the name of the product. The URL was:
http://www.andersonplywood.com/HARD-SANDER-BACKING-PAD-FOR-ETS-150-LEX-150-SANDERS%2C-D150%2C-1-PACK-Festool-FES498988/
and this is redirected to:
http://www.andersonplywood.com/HARD-SANDER-BACKING-PAD-FOR-ETS-150-LEX-150-SANDERS%2C-D150%2C-1-PACK-Festool-498988-FES498988/

In the second example the URL was customized. The old URL was:
http://www.andersonplywood.com/plywood/phenolic-plywood/
and it has been redirected to:
http://www.andersonplywood.com/Phenolic-Plywood/284/

Best regards,
Belén


#8

Hi Belen,

Thanks for your quick response.
You are right about the 2nd example.
But about the first one, GWT was reading the URLs from sitemap with “commas” instead of "%2C"s.
I deleted the current sitemap in GWT and submitted it again.
Hopefully it is going to be resolved. Will get back to you if it pops up in crawl errors again.

Best,
Mohsen


#9

@belen_ibanez
Hi Belen,

GWT started to crawl pages with “commas” in their URLs again, which leads to page not founds.
What do you suggest? Should we change product names and omit commas? Is there anything else we can do to avoid this error?

Thanks,
Mohsen


#10

@belen_ibanez

Hi Belen,

Any thoughts on this?
I have enabled “Enable SEO URL normalization (strip non-alphanumeric characters)” on our webstore.
Will this help?

Thanks,
Mohsen


#11

Hi Mohsen,

Sorry, could you clarify what you mean with ‘GWT started to crawl pages with “commas” in their URLs again’?

Your sitemap has not commas in the URLs as you can see it here.

The normalization will remove all the alphanumeric characters from the URLs, but your URL are already well formed (with the commas encoded) so I don’t think it will make a big difference. What is happening is that we encode the commas so the URLs are URI compliant but the other part is considering them save enough to use them in the URL.


#12

Hi Mohsen,

I have asked a colleague and that feature should solve your issue. It doesn’t encode the characters it removes them so the URLs in Google will be exactly as the one in the store.

Best regards,
Belén


#13

Hi Belen, @belen_ibanez

I mean, when I check my crawl errors in my Google Webmaster Tools, it still picks up URLs with “commas” instead of “%2c” although as you say they are correct in the sitemap.xml.

One more thing, Enabling SEO URL normalization has not been effective.
Check the following example:
http://www.andersonplywood.com/HEAVY-DUTY-OIL-REFILL-FOR-SURFIX%2C-2-PACK-OF-0.3-LITERS-Festool-498064-FES498064/
I am still getting commas or %2Cs in my URLs.
Aren’t they supposed to be removed after enabling SEO URL normalization?

Best,
Mohsen


#14

Hi Mohsen,

You would need to update the URL format or to remove and add the products again.

To update the URL you just need to change the format in the WSM for example:

Product Type

/%product_name%-%product_brandname%-%product_subdescription3%-%product_code%/1

and then update again the URL format to the version you really want:

 /%product_name%-%product_brandname%-%product_subdescription3%-%product_code%/

Best regards,
Belén


#15

Perfect!
It worked!

Thanks,
Mohsen